<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8"/>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=194-2&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=194-2&cb=3', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=194-2&cb=5', false, [], true, false, true, false);</script>  <meta http-equiv="X-UA-Compatible" content="IE=edge"/> <meta name="viewport" content="width=device-width, initial-scale=1"/> <link rel="profile" href="http://gmpg.org/xfn/11"/> <link rel="shortcut icon" href="/wp-content/uploads/2019/12/TIR-Stylized-R.png" type="image/x-icon"/> <link rel="apple-touch-icon" sizes="180x180" href="/wp-content/uploads/2019/12/TIR-Stylized-R.png"/> <link rel="alternate" type="application/rss+xml" title="This Is Reno RSS Feed" href="/feed/"/> <link rel="alternate" type="application/atom+xml" title="This Is Reno Atom Feed" href="/feed/atom/"/> <link rel="pingback" href="/xmlrpc.php"/> <!--[if lt IE 9]> <script src="/wp-content/themes/soledad/js/html5.js"></script> <![endif]--> <link rel="preconnect" href="//fonts.googleapis.com/"/> <link rel="preconnect" href="//fonts.gstatic.com/"/> <meta http-equiv="x-dns-prefetch-control" content="on"/> <link rel="dns-prefetch" href="//fonts.googleapis.com/"/> <link rel="dns-prefetch" href="//fonts.gstatic.com/"/> <link rel="dns-prefetch" href="//s.gravatar.com/"/> <link rel="dns-prefetch" href="//cdnjs.cloudflare.com/"/> <link rel="dns-prefetch" href="//ajax.googleapis.com/"/> <link rel="dns-prefetch" href="//www.google-analytics.com/"/> <link rel="preload" as="image" href="/wp-content/uploads/2019/12/This-Is-Reno-Logo-240.png" type="image/png"/> <link rel="preload" as="font" href="/wp-content/themes/soledad/fonts/fontawesome-webfont.woff2" type="font/woff2" crossorigin="anonymous"/> <link rel="preload" as="font" href="/wp-content/themes/soledad/fonts/icomoon.woff" type="font/woff" crossorigin="anonymous"/> <link rel="preload" as="font" href="/wp-content/themes/soledad/fonts/weathericons.woff2" type="font/woff2" crossorigin="anonymous"/> <meta property="og:locale" content="en_US"/> <meta property="og:type" content="article"/> <meta property="og:title" content="School board to meet earlier as agendas remain lengthy"/> <meta property="og:description" content="School board meetings are set to start at 2 p.m. for now as recent meetings have lasted eight hours or more."/> <meta property="og:url" content="https://thisisreno.com/2021/04/school-board-to-meet-earlier-as-agendas-remain-lengthy/"/> <meta property="og:site_name" content="This Is Reno"/> <meta property="article:tag" content="Washoe County School District"/> <meta property="article:section" content="Education"/> <meta property="article:published_time" content="2021-04-02T16:45:00-07:00"/> <meta property="article:modified_time" content="2021-04-02T14:27:41-07:00"/> <meta property="og:updated_time" content="2021-04-02T14:27:41-07:00"/> <meta property="og:image" content="https://thisisreno.com/wp-content/uploads/2021/03/WCSD_Board-Of-Trustees_3-30-21_EricMarks9864-scaled.jpg"/> <meta property="og:image:secure_url" content="https://thisisreno.com/wp-content/uploads/2021/03/WCSD_Board-Of-Trustees_3-30-21_EricMarks9864-scaled.jpg"/> <title>School board to meet earlier as agendas remain lengthy</title> <meta name="description" content="School board meetings are set to start at 2 p.m. for now as recent meetings have lasted eight hours or more."/> <meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"/> <link rel="canonical" href="https://thisisreno.com/2021/04/school-board-to-meet-earlier-as-agendas-remain-lengthy/"/> <meta property="og:locale" content="en_US"/> <meta property="og:type" content="article"/> <meta property="og:title" content="School board to meet earlier as agendas remain lengthy"/> <meta property="og:description" content="School board meetings are set to start at 2 p.m. for now as recent meetings have lasted eight hours or more."/> <meta property="og:url" content="https://thisisreno.com/2021/04/school-board-to-meet-earlier-as-agendas-remain-lengthy/"/> <meta property="og:site_name" content="This Is Reno"/> <meta property="article:publisher" content="https://www.facebook.com/ThisIsReno"/> <meta property="article:published_time" content="2021-04-02T23:45:00+00:00"/> <meta property="article:modified_time" content="2021-04-02T21:27:41+00:00"/> <meta property="og:image" content="https://thisisreno.com/wp-content/uploads/2021/03/WCSD_Board-Of-Trustees_3-30-21_EricMarks9864-scaled.jpg"/> <meta property="og:image:width" content="2560"/> <meta property="og:image:height" content="1707"/> <meta name="twitter:card" content="summary_large_image"/> <meta name="twitter:creator" content="@thisisreno"/> <meta name="twitter:site" content="@thisisreno"/> <meta name="twitter:label1" content="Written by"/> <meta name="twitter:data1" content="Jeri Davis"/> <meta name="twitter:label2" content="Est. reading time"/> <meta name="twitter:data2" content="3 minutes"/> <script type="application/ld+json" class="yoast-schema-graph">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</script> <link rel="dns-prefetch" href="//d136vqv78sbpmb.cloudfront.net/"/> <link rel="dns-prefetch" href="//s.w.org/"/> <link rel="alternate" type="application/rss+xml" title="This Is Reno » Feed" href="/feed/"/> <link rel="alternate" type="application/rss+xml" title="This Is Reno » Comments Feed" href="/comments/feed/"/> <link rel="alternate" type="application/rss+xml" title="This Is Reno » School board to meet earlier as agendas remain lengthy Comments Feed" href="feed/"/> <link rel="stylesheet" id="wp-block-library-css" href="/wp-includes/css/dist/block-library/style.min.css" type="text/css" media="all"/> <link rel="stylesheet" id="wp-block-library-theme-css" href="/wp-includes/css/dist/block-library/theme.min.css" type="text/css" media="all"/> <link rel="stylesheet" id="ugb-style-css-css" href="/wp-content/plugins/stackable-ultimate-gutenberg-blocks-premium/dist/frontend_blocks.css" type="text/css" media="all"/> <style id="ugb-style-css-inline-css" type="text/css"> :root { --content-width: 1170px; } </style> <link rel="stylesheet" id="ugb-style-css-deprecated-css" href="/wp-content/plugins/stackable-ultimate-gutenberg-blocks-premium/dist/frontend_blocks_deprecated.css" type="text/css" media="all"/> <link rel="stylesheet" id="ugb-style-css-premium-css" href="/wp-content/plugins/stackable-ultimate-gutenberg-blocks-premium/dist/frontend_blocks__premium_only.css" type="text/css" media="all"/> <link rel="stylesheet" id="ugb-style-css-premium-deprecated-css" href="/wp-content/plugins/stackable-ultimate-gutenberg-blocks-premium/dist/frontend_blocks_deprecated__premium_only.css" type="text/css" media="all"/> <link rel="stylesheet" id="foobox-free-min-css" href="/wp-content/plugins/foobox-image-lightbox/free/css/foobox.free.min.css" type="text/css" media="all"/> <link rel="stylesheet" id="penci-main-style-css" href="/wp-content/themes/soledad/main.min.css" type="text/css" media="all"/> <link rel="stylesheet" id="penci-font-awesomeold-css" href="/wp-content/themes/soledad/css/font-awesome.4.7.0.min.css" type="text/css" media="all"/> <link rel="stylesheet" id="penci-font-iconmoon-css" href="/wp-content/themes/soledad/css/iconmoon.css" type="text/css" media="all"/> <link rel="stylesheet" id="penci-font-iweather-css" href="/wp-content/themes/soledad/css/weather-icon.css" type="text/css" media="all"/> <link rel="stylesheet" id="penci_style-css" href="/wp-content/themes/soledad/style.css" type="text/css" media="all"/> <link rel="stylesheet" id="essb-compiledcache-css" href="/wp-content/easysocialsharebuttons-assets/compiled/2566c291e59e185c12a331fef1e235f3.css" type="text/css" media="all"/> <script type="text/javascript" id="ugb-block-frontend-js-js-extra">
/* <![CDATA[ */
var stackable = {"restUrl":"https:\/\/thisisreno.com\/wp-json\/"};
/* ]]> */
</script> <script type="text/javascript" src="https://thisisreno.com/wp-content/plugins/stackable-ultimate-gutenberg-blocks-premium/dist/frontend_blocks.js" id="ugb-block-frontend-js-js"></script> <script type="text/javascript" src="https://thisisreno.com/wp-content/plugins/stackable-ultimate-gutenberg-blocks-premium/dist/frontend_blocks__premium_only.js" id="ugb-block-frontend-js-premium-js"></script> <script type="text/javascript" data-cfasync="false" id="broadstreet-cdn-js" data-type="lazy" data-src="//d136vqv78sbpmb.cloudfront.net/init-2.min.js"></script> <script type="text/javascript" src="https://thisisreno.com/wp-includes/js/jquery/jquery.min.js" id="jquery-core-js"></script> <script type="text/javascript" src="https://thisisreno.com/wp-includes/js/jquery/jquery-migrate.min.js" id="jquery-migrate-js"></script> <script type="text/javascript" id="read-more.js-js-extra">
/* <![CDATA[ */
var pp_vars = {"publisher_id":"3a689dcf-1cc6-4ec9-abce-25be8bf70690","widget_endpoint":"https:\/\/gadget.pico.tools","plugin_version":"1.0.1","widget_version":"04.04.21.00.08","pico_context":"gadget","post_id":"176310","post_type":"post","post_title":"School board to meet earlier as agendas remain lengthy","taxonomies_for_this_post_type":["category","post_tag","post_format"],"list_of_taxonomies":["category","post_tag","nav_menu","link_category","post_format","foogallery_attachment_tag","foogallery_attachment_category"],"show_read_more_button":"1","taxonomies":{"category":["education","featured","government","news"],"post_tag":["washoe county school district"]},"resource_ref":"year=2021&monthnum=04&name=school-board-to-meet-earlier-as-agendas-remain-lengthy"};
/* ]]> */
</script> <script type="text/javascript" src="https://thisisreno.com/wp-content/plugins/pico/includes/js/read-more.js" id="read-more.js-js"></script> <script type="text/javascript" id="foobox-free-min-js-before">
/* Run FooBox FREE (v2.7.16) */
var FOOBOX = window.FOOBOX = {
	ready: true,
	disableOthers: false,
	o: {wordpress: { enabled: true }, hideScrollbars:false, excludes:'.fbx-link,.nofoobox,.nolightbox,a[href*="pinterest.com/pin/create/button/"]', affiliate : { enabled: false }, error: "Could not load the item"},
	selectors: [
		".foogallery-container.foogallery-lightbox-foobox", ".foogallery-container.foogallery-lightbox-foobox-free", ".gallery", ".wp-block-gallery", ".wp-caption", ".wp-block-image", "a:has(img[class*=wp-image-])", ".foobox"
	],
	pre: function( $ ){
		// Custom JavaScript (Pre)
		
	},
	post: function( $ ){
		// Custom JavaScript (Post)
		
		// Custom Captions Code
		
	},
	custom: function( $ ){
		// Custom Extra JS
		
	}
};
</script> <script type="text/javascript" src="https://thisisreno.com/wp-content/plugins/foobox-image-lightbox/free/js/foobox.free.min.js" id="foobox-free-min-js"></script> <link rel="https://api.w.org/" href="/wp-json/"/><link rel="alternate" type="application/json" href="/wp-json/wp/v2/posts/176310"/><link rel="EditURI" type="application/rsd+xml" title="RSD" href="/xmlrpc.php?rsd"/> <link rel="shortlink" href="/?p=176310"/> <link rel="alternate" type="application/json+oembed" href="/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F"/> <link rel="alternate" type="text/xml+oembed" href="/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F&amp;format=xml"/> <script data-cfasync="false" data-type="lazy" data-src="data:text/javascript;base64,d2luZG93LmJyb2Fkc3RyZWV0S2V5d29yZHMgPSBbJ25vdF9ob21lX3BhZ2UnLCdub3RfbGFuZGluZ19wYWdlJywnaXNfYXJ0aWNsZV9wYWdlJywnZWR1Y2F0aW9uJywnbmV3cycsJ2ZlYXR1cmVkJywnZ292ZXJubWVudCcsJ25ld3MnLCduZXdzJywnc2Nob29sLWJvYXJkLXRvLW1lZXQtZWFybGllci1hcy1hZ2VuZGFzLXJlbWFpbi1sZW5ndGh5JywncG9zdCdd"></script> <script data-cfasync="false" data-type="lazy" data-src="data:text/javascript;base64,d2luZG93LmJyb2Fkc3RyZWV0VGFyZ2V0cyA9IHsicGFnZXR5cGUiOlsicG9zdCIsIm5vdF9ob21lX3BhZ2UiXSwiY2F0ZWdvcnkiOlsiZWR1Y2F0aW9uIiwibmV3cyIsImZlYXR1cmVkIiwiZ292ZXJubWVudCIsIm5ld3MiLCJuZXdzIiwic2Nob29sLWJvYXJkLXRvLW1lZXQtZWFybGllci1hcy1hZ2VuZGFzLXJlbWFpbi1sZW5ndGh5IiwicG9zdCJdLCJ1cmwiOiJzY2hvb2wtYm9hcmQtdG8tbWVldC1lYXJsaWVyLWFzLWFnZW5kYXMtcmVtYWluLWxlbmd0aHkifTs="></script> <script data-cfasync="false" data-type="lazy" data-src="data:text/javascript;base64,CndpbmRvdy5icm9hZHN0cmVldCA9IHdpbmRvdy5icm9hZHN0cmVldCB8fCB7IHJ1bjogW10gfTt3aW5kb3cuYnJvYWRzdHJlZXQucnVuLnB1c2goZnVuY3Rpb24gKCkgewp3aW5kb3cuYnJvYWRzdHJlZXQubG9hZE5ldHdvcmtKUygyNjE4LCB7IGRvbWFpbjogJ3RoaXNpc3Jlbm8tc3BvbnNvcnMuc3RyZWV0aW50ZXJhY3RpdmUuY29tJ30pOwogfSk7"></script> <script type="text/javascript">var essb_settings = {"ajax_url":"https:\/\/thisisreno.com\/wp-admin\/admin-ajax.php","essb3_nonce":"284ad0e4a0","essb3_plugin_url":"https:\/\/thisisreno.com\/wp-content\/plugins\/easy-social-share-buttons3","essb3_stats":false,"essb3_ga":true,"essb3_ga_mode":"simple","blog_url":"https:\/\/thisisreno.com\/","post_id":"176310","aftershare_networks":""};</script><script id="mcjs" data-type="lazy" data-src="data:text/javascript;base64,IWZ1bmN0aW9uKGMsaCxpLG0scCl7bT1jLmNyZWF0ZUVsZW1lbnQoaCkscD1jLmdldEVsZW1lbnRzQnlUYWdOYW1lKGgpWzBdLG0uYXN5bmM9MSxtLnNyYz1pLHAucGFyZW50Tm9kZS5pbnNlcnRCZWZvcmUobSxwKX0oZG9jdW1lbnQsInNjcmlwdCIsImh0dHBzOi8vY2hpbXBzdGF0aWMuY29tL21janMtY29ubmVjdGVkL2pzL3VzZXJzL2U4Yzc3NDU2OWRlYTcyOTQwY2RlZDU5OGIvNmFiY2U5MTA0YTJhYzU5OWEyMWRiODhkNC5qcyIpOw=="></script> <meta name="google-site-verification" content="IsX6acIHYg29yJ-Nks5235kPicBgFT1tQCokQHpSJjA"/> <script>
    (function(c,l,a,r,i,t,y){
        c[a]=c[a]||function(){(c[a].q=c[a].q||[]).push(arguments)};
        t=l.createElement(r);t.async=1;t.src="https://www.clarity.ms/tag/"+i;
        y=l.getElementsByTagName(r)[0];y.parentNode.insertBefore(t,y);
    })(window, document, "clarity", "script", "5a321t5q9y");
</script> <script data-ad-client="ca-pub-8390888470013947" async="" data-type="lazy" data-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><style id="penci-custom-style" type="text/css">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</style><script>
var penciBlocksArray=[];
var portfolioDataJs = portfolioDataJs || [];var PENCILOCALCACHE = {};
		(function () {
				"use strict";
		
				PENCILOCALCACHE = {
					data: {},
					remove: function ( ajaxFilterItem ) {
						delete PENCILOCALCACHE.data[ajaxFilterItem];
					},
					exist: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data.hasOwnProperty( ajaxFilterItem ) && PENCILOCALCACHE.data[ajaxFilterItem] !== null;
					},
					get: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data[ajaxFilterItem];
					},
					set: function ( ajaxFilterItem, cachedData ) {
						PENCILOCALCACHE.remove( ajaxFilterItem );
						PENCILOCALCACHE.data[ajaxFilterItem] = cachedData;
					}
				};
			}
		)();function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}</script> <script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/thisisreno.com\/wp-content\/uploads\/2019\/12\/This-Is-Reno-Logo-240.png"
    },
    "url": "https:\/\/thisisreno.com\/",
    "name": "This Is Reno",
    "description": "Reno news and events, updated daily"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "This Is Reno",
    "alternateName": "Reno news and events, updated daily",
    "url": "https:\/\/thisisreno.com\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "School board to meet earlier as agendas remain lengthy",
    "description": "School board meetings are set to start at 2 p.m. for now as recent meetings have lasted eight hours or more.",
    "datePublished": "2021-04-02",
    "datemodified": "2021-04-02",
    "mainEntityOfPage": "https:\/\/thisisreno.com\/2021\/04\/school-board-to-meet-earlier-as-agendas-remain-lengthy\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/thisisreno.com\/wp-content\/uploads\/2021\/03\/WCSD_Board-Of-Trustees_3-30-21_EricMarks9864-scaled.jpg",
        "width": 2560,
        "height": 1707
    },
    "publisher": {
        "@type": "Organization",
        "name": "This Is Reno",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/thisisreno.com\/wp-content\/uploads\/2019\/12\/This-Is-Reno-Logo-240.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-JeriDavis",
        "name": "Jeri Davis"
    }
}</script> <script type="text/javascript">
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
</script> <script type="text/javascript">
  fbq('init', '823136344378209', {}, {
    "agent": "wordpress-5.6-3.0.5"
});
</script><script type="text/javascript">
  fbq('track', 'PageView', []);
</script> <noscript> <img height="1" width="1" style="display:none" alt="fbpx" src="//www.facebook.com/tr?id=823136344378209&ev=PageView&noscript=1"/> </noscript> <meta name="onesignal" content="wordpress-plugin"/> <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://thisisreno.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '523a5d8e-9261-46dd-8c20-02f2522f4577';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "This Is Reno";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://thisisreno.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.20044851-a7f8-4507-9604-3e42dc43ffbf";
oneSignal_options['persistNotification'] = true;
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-left';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = false;
oneSignal_options['notifyButton']['text'] = {};
oneSignal_options['notifyButton']['offset'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script> <link rel="icon" href="/wp-content/uploads/2019/12/TIR-Stylized-R.png" sizes="32x32"/> <link rel="icon" href="/wp-content/uploads/2019/12/TIR-Stylized-R.png" sizes="192x192"/> <link rel="apple-touch-icon" href="/wp-content/uploads/2019/12/TIR-Stylized-R.png"/> <meta name="msapplication-TileImage" content="https://thisisreno.com/wp-content/uploads/2019/12/TIR-Stylized-R.png"/> <script type="text/javascript">var ezouid = "1";</script><base href="https://thisisreno.com/2021/04/school-board-to-meet-earlier-as-agendas-remain-lengthy/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 148879;
var ezdomain = 'thisisreno.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":148879,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"04664a8f-7133-4362-6302-3ad9222ada7c","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":129671,"response_time_orig":6,"serverid":"3.89.9.16:23199","state":"VA","t_epoch":1617545297,"template_id":126,"time_on_site_visit":0,"url":"https://thisisreno.com/2021/04/school-board-to-meet-earlier-as-agendas-remain-lengthy/","user_id":0,"word_count":1036,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_148879=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["04664a8f-7133-4362-6302-3ad9222ada7c", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head> <body class="post-template-default single single-post postid-176310 single-format-standard essb-7.9 penci-body-single-style-4 penci-show-pthumb"> <a id="close-sidebar-nav" class="header-4"><i class="penci-faicon fa fa-close"></i></a> <nav id="sidebar-nav" class="header-4" role="navigation" itemscope="" itemtype="https://schema.org/SiteNavigationElement"> <div id="sidebar-nav-logo"> <a href="/"><img class="penci-lazy" src="/wp-content/themes/soledad/images/penci-holder.png" data-src="/wp-content/uploads/2019/12/This-Is-Reno-Logo-240.png" alt="This Is Reno"/></a> </div> <div class="header-social sidebar-nav-social penci-social-textcolored"> <div class="inner-header-social"> <a href="//www.facebook.com/thisisreno" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook"></i></a> <a href="//twitter.com/thisisreno" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter"></i></a> <a href="//www.instagram.com/thisisreno/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram"></i></a> <a href="//www.linkedin.com/company/6406449" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin"></i></a> <a href="//www.youtube.com/c/thisisreno" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i></a> <a href="/contact/"><i class="penci-faicon fa fa-envelope"></i></a> <a href="//soundcloud.com/thisisreno-com" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-soundcloud"></i></a> <a href="//open.spotify.com/show/78biX0mtXol5MxbWw7iDxY" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-spotify"></i></a> <a href="/feed/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss"></i></a> </div> </div> <ul id="menu-main-navigation" class="menu"><li id="menu-item-161927" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-161927"><a title="This Is Reno Home" href="/">Home</a> <ul class="sub-menu"> <li id="menu-item-161929" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-161929"><a title="About This Is Reno" href="/about/">About</a></li> <li id="menu-item-161931" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-161931"><a title="Contact" href="/contact/">Contact</a></li> </ul> </li> <li id="menu-item-163474" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-163474"><a href="/subscribe/">Subscribe</a></li> <li id="menu-item-10608" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-10608"><a title="Reno News" href="/category/news/">News</a></li> <li id="menu-item-170002" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-170002"><a href="/calendar/">Events</a></li> <li id="menu-item-166165" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-166165"><a href="/category/en-espanol/">En Español</a></li> <li id="menu-item-171961" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-171961"><a href="/restaurants/#/">Businesses</a> <ul class="sub-menu"> <li id="menu-item-173901" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-173901"><a href="//hub.cityspark.com/listing/Submission/ThisIsRenoDining?picktype=true">Add a Business</a></li> <li id="menu-item-171960" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171960"><a href="/restaurants/">Restaurants</a></li> <li id="menu-item-171959" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171959"><a href="/attractions/">Attractions</a></li> <li id="menu-item-171956" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171956"><a href="/travel-3/">Travel</a></li> <li id="menu-item-171957" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171957"><a href="/services/">Services</a></li> <li id="menu-item-171958" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171958"><a href="/retail/">Retail</a></li> </ul> </li> </ul> </nav> <div class="wrapper-boxed header-style-header-4 penci-hlogo-center"> <div class="penci-header-wrap"> <nav id="navigation" class="header-layout-top header-4 menu-style-2 menu-item-padding" role="navigation" itemscope="" itemtype="https://schema.org/SiteNavigationElement"> <div class="container"> <div class="button-menu-mobile header-1"><i class="penci-faicon fa fa-bars"></i></div> <ul id="menu-main-navigation-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-161927"><a title="This Is Reno Home" href="/">Home</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-161929"><a title="About This Is Reno" href="/about/">About</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-161931"><a title="Contact" href="/contact/">Contact</a></li> </ul> </li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-163474"><a href="/subscribe/">Subscribe</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-10608"><a title="Reno News" href="/category/news/">News</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-170002"><a href="/calendar/">Events</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-166165"><a href="/category/en-espanol/">En Español</a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-171961"><a href="/restaurants/#/">Businesses</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-173901"><a href="//hub.cityspark.com/listing/Submission/ThisIsRenoDining?picktype=true">Add a Business</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171960"><a href="/restaurants/">Restaurants</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171959"><a href="/attractions/">Attractions</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171956"><a href="/travel-3/">Travel</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171957"><a href="/services/">Services</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171958"><a href="/retail/">Retail</a></li> </ul> </li> </ul> <div id="top-search" class="penci-top-search"> <a class="search-click"><i class="penci-faicon fa fa-search"></i></a> <div class="show-search"> <form role="search" method="get" id="searchform" action="/"> <div> <input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s"/> </div> </form> <a class="search-click close-search"><i class="penci-faicon fa fa-close"></i></a> </div> </div> </div> </nav> <header id="header" class="penci-header-second header-header-4 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader"> <div class="inner-header"> <div class="container"> <div id="logo"> <a href="/"><img src="/wp-content/uploads/2019/12/This-Is-Reno-Logo-240.png" alt="This Is Reno"/></a> </div> <div class="header-social"> <div class="inner-header-social"> <a href="//www.facebook.com/thisisreno" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook"></i></a> <a href="//twitter.com/thisisreno" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter"></i></a> <a href="//www.instagram.com/thisisreno/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram"></i></a> <a href="//www.linkedin.com/company/6406449" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin"></i></a> <a href="//www.youtube.com/c/thisisreno" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i></a> <a href="/contact/"><i class="penci-faicon fa fa-envelope"></i></a> <a href="//soundcloud.com/thisisreno-com" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-soundcloud"></i></a> <a href="//open.spotify.com/show/78biX0mtXol5MxbWw7iDxY" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-spotify"></i></a> <a href="/feed/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss"></i></a> </div> </div> </div> </div> </header> </div><div class="penci-single-pheader container-single penci-single-style-4 penci-single-smore container-single-fullwidth hentry container-single-magazine penci_is_nosidebar"> <div class="container penci-container-inside penci-breadcrumb single-breadcrumb"><span><span><a href="/">Home</a> &gt; <span><a href="/category/featured/">Featured</a> &gt; <strong class="breadcrumb_last" aria-current="page">School board to meet earlier as agendas remain lengthy</strong></span></span></span></div><div class="container"><div class="header-standard header-classic single-header"> <div class="penci-standard-cat penci-single-cat"><span class="cat"><a class="penci-cat-name penci-cat-4085" href="/category/featured/" rel="category tag">Featured</a></span></div> <h1 class="post-title single-post-title entry-title">School board to meet earlier as agendas remain lengthy</h1> <div class="penci-hide-tagupdated"> <span class="author-italic author vcard">By <a class="url fn n" href="/author/jeri-davis/">Jeri Davis</a></span> <time class="entry-date published" datetime="2021-04-02T16:45:00-07:00">April 2, 2021</time> </div> <div class="post-box-meta-single"> <span class="author-post byline"><span class="author vcard">By <a class="author-url url fn n" href="/author/jeri-davis/">Jeri Davis</a></span></span> <span><time class="entry-date published" datetime="2021-04-02T16:45:00-07:00">April 2, 2021</time></span> </div> </div> </div> <div class="post-image penci-jarallax"> <img class="jarallax-img" src="/wp-content/uploads/2021/03/WCSD_Board-Of-Trustees_3-30-21_EricMarks9864-1920x1280.jpg" alt=""/><div class="penci-featured-caption">Washoe County School District Board of Trustees meet at Damonte Ranch High School for their March 30, 2021 meeting. Image: Eric Marks / This Is Reno</div> </div> </div> <div class="container container-single penci-single-style-4 penci-single-smore penci_is_nosidebar penci-single-smaller-width penci-enable-lightbox"> <div id="main" class="penci-main-sticky-sidebar"> <div class="theiaStickySidebar"> <article id="post-176310" class="post type-post status-publish"> <div class="post-entry blockquote-style-1"> <div class="inner-post-entry entry-content" id="penci-post-entry-inner"> <div style="margin:5px auto; margin-bottom: 15px;" id="zone_load_870939084"><broadstreet-zone callback="zone_load_870939084" zone-id="77490" keywords="not_home_page,not_landing_page,is_article_page,education,news,featured,government,news,news,school-board-to-meet-earlier-as-agendas-remain-lengthy,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div><script>window.zone_load_870939084 = function(z, d) { if (!d.count) document.getElementById('zone_load_870939084').style.display = 'none'; };</script><div class="essb_links essb_counters essb_displayed_top essb_share essb_content_responsive essb_template_default4-retina essb_template_glow-retina essb_178220069 essb_size_s essb_width_flex essb_network_align_center essb_responsive_adaptive essb_icon_animation3 essb_nospace essb_mobile_hidden print-no" id="essb_displayed_top_178220069" data-essb-postid="176310" data-essb-position="top" data-essb-button-style="vertical" data-essb-template="default4-retina essb_template_glow-retina" data-essb-counter-pos="hidden" data-essb-url="https://thisisreno.com/2021/04/school-board-to-meet-earlier-as-agendas-remain-lengthy/" data-essb-fullurl="https://thisisreno.com/2021/04/school-board-to-meet-earlier-as-agendas-remain-lengthy/" data-essb-instance="178220069"><ul class="essb_links_list essb_vertical_name"><li class="essb_item essb_totalcount_item" style="display: none !important;" data-essb-hide-till="9" data-counter-pos="hidden"><span class="essb_totalcount essb_t_l_big" data-shares-text="shares"><span class="essb_t_nb">5<span class="essb_t_nb_after">shares</span></span></span></li><li class="essb_item essb_link_facebook nolightbox"> <a href="//www.facebook.com/dialog/feed?app_id=551468291535482&amp;display=popup&amp;name=School+board+to+meet+earlier+as+agendas+remain+lengthy&amp;link=https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F&amp;picture=https://thisisreno.com/wp-content/uploads/2021/03/WCSD_Board-Of-Trustees_3-30-21_EricMarks9864-scaled.jpg&amp;description=School+board+meetings+are+set+to+start+at+2+p.m.+for+now+as+recent+meetings+have+lasted+eight+hours+or+more." title="Share on Share" onclick="essb.window(&#39;https://www.facebook.com/dialog/feed?app_id=551468291535482&amp;display=popup&amp;name=School+board+to+meet+earlier+as+agendas+remain+lengthy&amp;link=https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F&amp;picture=https://thisisreno.com/wp-content/uploads/2021/03/WCSD_Board-Of-Trustees_3-30-21_EricMarks9864-scaled.jpg&amp;description=School+board+meetings+are+set+to+start+at+2+p.m.+for+now+as+recent+meetings+have+lasted+eight+hours+or+more.&#39;,&#39;facebook_advanced&#39;,&#39;178220069&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Share</span></a><span class="essb_counter_hidden" data-cnt="5" data-cnt-short=""></span></li><li class="essb_item essb_link_facebook nolightbox"> <a href="//www.facebook.com/plugins/like.php?href=https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F" title="Share on Like" onclick="essb.window(&#39;https://www.facebook.com/plugins/like.php?href=https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F&#39;,&#39;facebook_like&#39;,&#39;178220069&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_facebook-official"></span><span class="essb_network_name">Like</span></a><span class="essb_counter_hidden" data-cnt="" data-cnt-short=""></span></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="Share on Tweet" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=School%20board%20to%20meet%20earlier%20as%20agendas%20remain%20lengthy&amp;url=https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F&amp;counturl=https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F&amp;related=thisisreno&amp;via=thisisreno&amp;hashtags=#ThisisReno&#39;,&#39;twitter&#39;,&#39;178220069&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Tweet</span></a><span class="essb_counter_hidden" data-cnt="" data-cnt-short=""></span></li><li class="essb_item essb_link_linkedin nolightbox"> <a href="//www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=School+board+to+meet+earlier+as+agendas+remain+lengthy&amp;url=https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F" title="Share on Share" onclick="essb.window(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=School+board+to+meet+earlier+as+agendas+remain+lengthy&amp;url=https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F&#39;,&#39;linkedin&#39;,&#39;178220069&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">Share</span></a><span class="essb_counter_hidden" data-cnt="" data-cnt-short=""></span></li><li class="essb_item essb_link_mail nolightbox"> <a href="mailto:?subject=Check%20out%20https%3A%2F%2Fthisisreno.com&amp;body=Hi%2C%20this%20may%20be%20interesting%20you%3A%20School%20board%20to%20meet%20earlier%20as%20agendas%20remain%20lengthy%21%20This%20is%20the%20link%3A%20https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F" title="Share on Email" onclick="essb.tracking_only(&#39;&#39;, &#39;mail&#39;, &#39;178220069&#39;, true);" target="_self" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_mail"></span><span class="essb_network_name">Email</span></a><span class="essb_counter_hidden" data-cnt="" data-cnt-short=""></span></li><li class="essb_item essb_link_whatsapp nolightbox"> <a href="whatsapp://send/?text=School%20board%20to%20meet%20earlier%20as%20agendas%20remain%20lengthy%20https://thisisreno.com/2021/04/school-board-to-meet-earlier-as-agendas-remain-lengthy/" title="Share on WhatsApp" onclick="essb.tracking_only(&#39;&#39;, &#39;whatsapp&#39;, &#39;178220069&#39;, true);" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_whatsapp"></span><span class="essb_network_name">WhatsApp</span></a><span class="essb_counter_hidden" data-cnt="" data-cnt-short=""></span></li><li class="essb_item essb_link_sms nolightbox"> <a href="sms:/&amp;body=School%20board%20to%20meet%20earlier%20as%20agendas%20remain%20lengthy%20https:/thisisreno.com/2021/04/school-board-to-meet-earlier-as-agendas-remain-lengthy/" title="Share on Text" onclick="essb.sms(&#39;School%20board%20to%20meet%20earlier%20as%20agendas%20remain%20lengthy%20https://thisisreno.com/2021/04/school-board-to-meet-earlier-as-agendas-remain-lengthy/&#39;, &#39;178220069&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_sms"></span><span class="essb_network_name">Text</span></a><span class="essb_counter_hidden" data-cnt="" data-cnt-short=""></span></li><li class="essb_item essb_link_messenger nolightbox"> <a href="fb-messenger://share/?link=https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F" title="Share on Send" onclick="essb.fbmessenger(&#39;551468291535482&#39;, &#39;https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F&#39;, &#39;178220069&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_messenger"></span><span class="essb_network_name">Send</span></a><span class="essb_counter_hidden" data-cnt="" data-cnt-short=""></span></li></ul></div><div id="pico"> <p class="has-drop-cap">Washoe schools Superintendent Kristen McNeill and Board of Trustees President Angie Taylor addressed today during a media briefing future board meetings and the proposed changes to board policy 4500 governing employees’ rights to free speech.</p> <h2 id="h-board-meetings-to-start-earlier"><strong>Board meetings to start earlier</strong> </h2> <p>For the time being, board meetings will begin at 2 p.m. This, according to Taylor, is necessitated by the length of board meetings—which have often stretched to more than eight hours during the pandemic, as the board grapples with its usual business along with agenda items resulting directly from the COVID-19 pandemic.</p> <p>Public comment periods will still take place at 4 p.m. to accommodate people who cannot arrive to meetings earlier. Public comments may also be made via email.</p> <p>Speakers during public comment periods have become increasingly animated in recent months. This was especially the case during <a href="../../03/another-raucous-meeting-for-the-washoe-county-school-board/">the most recent board of trustees meeting</a>, during which some commenters who were critical of the board and its actions violated state-mandated COVID-19 mitigation directives and were disruptive to the point of sending the meeting into a brief recess.</p> <p>“As a reminder, all attendees will be required to wear face coverings to adhere to the governor’s directives and physical distancing, which fell apart a little bit last time,” Taylor said. “We want physical distancing to be strictly enforced because we want people to be safe.”  </p> <h2 id="h-employee-speech-restrictions-still-under-consideration"><strong>Employee speech restrictions still under consideration </strong> </h2> <p>During its Tuesday meeting, the board passed its policy 1310 concerning political speech on school property and opened the issue for a <a href="//www.washoeschools.net/domain/695" target="_blank" rel="noreferrer noopener">13-day public comment period</a>. Its <a href="../../03/school-board-argues-hours-over-revision-of-policy-on-employee-speech/">policy 4500 concerning employee free speech rights</a>, however, was sent back to the board’s policy committee for further review.</p> <p>Proposed changes to the policy would prohibit district employees from speaking to the media about work-related concerns or complaints, despite the fact that employees in general—and public employees, specifically—have a right to speak freely with the press without first seeking approval from their employers.</p> <p>Critics have called the policy blatantly authoritarian, and experts say it’s illegal and legally unenforceable.</p> <p>Taylor called the policy “complicated” and said, “We certainly don’t want teachers to feel as though their freedom of expression is being limited. At the same time, we recognize that the district, in and of itself, has a voice as well.”</p> <p>In regard to the would-be workplace gag order imposed by the policy revision, she said, “I think some clarity around what that looks like is part of what we’ll be looking at again as we review policy 4500. One of the .. public comments was from Phil Kaiser, who’s the president of the Washoe Education Association, our teachers’ union … and we know there are some concerns around that, and we wanted more clarity around that and to ask some questions as well.</p> <p>“We’re going to dig into it a little bit more,” she added “So, we don’t have a resolution yet … because there’s some things we need to work through.”</p> <p>McNeill echoed Taylor’s explanation of the extended review of the policy, adding that she felt the district’s legal counsel had done a good job in drafting it.</p> <p>“I will say our chief counsel and the office of general counsel spent a great deal of time researching both board policy 1310 and 4500, as was directed by our board,” McNeill said. “They really did a deep dive—looked at other districts across the country, looked at research. So, I believe very much in the work of our chief counsel [Neil] Rombardo and his team and what they were able to put forward—but we also want to make sure that we have the input from our employee associations…”  </p> </div><div style="margin:5px auto; margin-bottom: 15px;" id="zone_load_597485928"><broadstreet-zone callback="zone_load_597485928" zone-id="64815" keywords="not_home_page,not_landing_page,is_article_page,education,news,featured,government,news,news,school-board-to-meet-earlier-as-agendas-remain-lengthy,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div><script>window.zone_load_597485928 = function(z, d) { if (!d.count) document.getElementById('zone_load_597485928').style.display = 'none'; };</script><div class="essb_break_scroll"></div> <div class="penci-single-link-pages"> </div> <div class="post-tags"> <a href="/tag/washoe-county-school-district/" rel="tag">Washoe County School District</a> </div> </div> </div> <div class="post-author"> <div class="author-img"> <img src="/wp-content/uploads/2020/05/jeriheadshot-150x150.jpg" width="100" height="100" alt="Jeri Davis" class="avatar avatar-100 wp-user-avatar wp-user-avatar-100 alignnone photo"/> </div> <div class="author-content"> <h5><a href="/author/jeri-davis/" title="Posts by Jeri Davis" rel="author">Jeri Davis</a></h5> <p>Jeri Davis came to Reno from rural Nevada in 2004 to study anthropology at the University of Nevada, Reno. In 2012, she returned to the university for a master’s degree in journalism. She is the former associate and news editor of the Reno News &amp; Review and is a recipient of first-place Nevada Press Association awards for investigative and business reporting. Jeri is passionate about Nevada’s history, politics and communities.</p> </div> </div> <div class="post-pagination"> <div class="prev-post"> <div class="prev-post-inner"> <div class="prev-post-title"> <span>previous post</span> </div> <a href="../donor-network-west-celebrates-national-donate-life-month-sponsored/"> <div class="pagi-text"> <h5 class="prev-title">Donor Network West celebrates National Donate Life Month (sponsored)</h5> </div> </a> </div> </div> <div class="next-post"> <div class="next-post-inner"> <div class="prev-post-title next-post-title"> <span>next post</span> </div> <a href="../se-abre-programacion-de-la-vacuna-covid-19-para-los-mayores-de-16-anos/"> <div class="pagi-text"> <h5 class="next-title">Se abre programación de la vacuna COVID-19 para los mayores de 16 años</h5> </div> </a> </div> </div> </div> <div class="post-related penci-posts-related-grid"> <div class="post-title-box"><h4 class="post-box-title">Related Stories</h4></div> <div class="penci-related-carousel penci-related-grid-display"> <div class="item-related"> <a class="related-thumb penci-image-holder penci-lazy" data-src="/wp-content/uploads/2020/08/WCSD-Board-8-11-20_EricMarks-29-585x390.jpg" href="../assembly-bill-would-make-washoe-county-school-board-partially-appointed/" title="Assembly bill would make Washoe County school board partially appointed"> </a> <h3><a href="../assembly-bill-would-make-washoe-county-school-board-partially-appointed/">Assembly bill would make Washoe County school board partially appointed</a></h3> <span class="date"><time class="entry-date published" datetime="2021-04-01T17:10:00-07:00">April 1, 2021</time></span> </div> <div class="item-related"> <a class="related-thumb penci-image-holder penci-lazy" data-src="/wp-content/uploads/2021/03/WCSD_Board-Of-Trustees_3-30-21_EricMarks9899-585x390.jpg" href="../../03/another-raucous-meeting-for-the-washoe-county-school-board/" title="Another raucous meeting for the Washoe County School Board"> </a> <h3><a href="../../03/another-raucous-meeting-for-the-washoe-county-school-board/">Another raucous meeting for the Washoe County School Board</a></h3> <span class="date"><time class="entry-date published" datetime="2021-03-31T15:45:42-07:00">March 31, 2021</time></span> </div> <div class="item-related"> <a class="related-thumb penci-image-holder penci-lazy" data-src="/wp-content/uploads/2018/02/washoe-county-school.jpg" href="../../03/school-district-mourns-loss-of-ben-hayes-wcsd-accountability-officer/" title="School district mourns loss of Ben Hayes, WCSD accountability officer"> </a> <h3><a href="../../03/school-district-mourns-loss-of-ben-hayes-wcsd-accountability-officer/">School district mourns loss of Ben Hayes, WCSD accountability officer</a></h3> <span class="date"><time class="entry-date published" datetime="2021-03-25T11:42:38-07:00">March 25, 2021</time></span> </div> <div class="item-related"> <a class="related-thumb penci-image-holder penci-lazy" data-src="/wp-content/uploads/2020/07/MarceHerz-School-Tour_Eric-Marks1444-585x390.jpg" href="../../03/el-distrito-escolar-continua-trabajando-para-que-los-ninos-regresen-a-las-aulas/" title="El distrito escolar continúa trabajando para que los niños regresen a las aulas"> </a> <h3><a href="../../03/el-distrito-escolar-continua-trabajando-para-que-los-ninos-regresen-a-las-aulas/">El distrito escolar continúa trabajando para que los niños regresen...</a></h3> <span class="date"><time class="entry-date published" datetime="2021-03-13T12:28:00-08:00">March 13, 2021</time></span> </div> <div class="item-related"> <a class="related-thumb penci-image-holder penci-lazy" data-src="/wp-content/uploads/2016/09/Bus-stop-4-copy-2.jpg" href="../../03/potential-zoning-changes-for-north-valleys-area-schools-discussed/" title="Potential zoning changes for North Valleys area schools discussed"> </a> <h3><a href="../../03/potential-zoning-changes-for-north-valleys-area-schools-discussed/">Potential zoning changes for North Valleys area schools discussed</a></h3> <span class="date"><time class="entry-date published" datetime="2021-03-12T14:38:00-08:00">March 12, 2021</time></span> </div> <div class="item-related"> <a class="related-thumb penci-image-holder penci-lazy" data-src="/wp-content/uploads/2020/07/MarceHerz-School-Tour_Eric-Marks1444-585x390.jpg" href="../../03/school-district-continues-work-to-return-children-to-classrooms/" title="School district continues work to return children to classrooms"> </a> <h3><a href="../../03/school-district-continues-work-to-return-children-to-classrooms/">School district continues work to return children to classrooms</a></h3> <span class="date"><time class="entry-date published" datetime="2021-03-10T18:15:00-08:00">March 10, 2021</time></span> </div> </div></div> </article> </div> </div> </div> <div class="clear-footer"></div> <div class="container penci-google-adsense penci-google-adsense-footer"><script async="" src="https://c.go-fet.ch/a/embed.js"></script> </div> <div id="widget-area"> <div class="container"> <div class="footer-widget-wrapper footer-widget-style-1"> <aside id="nav_menu-21" class="widget widget_nav_menu"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Site Navigation</span></h4><div class="menu-footer-1-site-navigation-container"><ul id="menu-footer-1-site-navigation" class="menu"><li id="menu-item-171497" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-171497"><a href="/">Home</a></li> <li id="menu-item-171505" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171505"><a href="/subscribe/">Subscribe</a></li> <li id="menu-item-171498" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171498"><a href="/about/">About This Is Reno</a></li> <li id="menu-item-171499" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171499"><a href="/about/thisisreno-crew/">The Team</a></li> <li id="menu-item-171500" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171500"><a href="/archives/">Archives</a></li> <li id="menu-item-171501" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171501"><a href="/calendar/">Calendar</a></li> <li id="menu-item-171502" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171502"><a href="/sitemap/">Sitemap</a></li> <li id="menu-item-171503" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171503"><a href="/contact/">Contact Us</a></li> </ul></div></aside> </div> <div class="footer-widget-wrapper footer-widget-style-1"> <aside id="nav_menu-20" class="widget widget_nav_menu"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Connect</span></h4><div class="menu-footer-2-engage-container"><ul id="menu-footer-2-engage" class="menu"><li id="menu-item-171506" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171506"><a href="/advertising/">Advertise With Us</a></li> <li id="menu-item-171515" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171515"><a href="/jobs/">Find a job in Reno</a></li> <li id="menu-item-171518" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171518"><a href="/commenting/">Commenting</a></li> <li id="menu-item-171517" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171517"><a href="/about/corrections-clarifications/">Corrections &amp; Clarifications</a></li> <li id="menu-item-171511" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171511"><a href="/submit-a-news-story/">Submit a News Story</a></li> <li id="menu-item-171512" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-171512"><a href="//portal.cityspark.com/EventEntry/EventEntry/ThisIsReno">Submit a Calendar Event</a></li> <li id="menu-item-171514" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171514"><a href="/contact/submit-an-opinion-article/">Submit an opinion article</a></li> <li id="menu-item-171516" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-171516"><a href="/privacy-policy/">Privacy Policy</a></li> </ul></div></aside> </div> <div class="footer-widget-wrapper footer-widget-style-1 last"> <aside id="penci_social_widget-10" class="widget penci_social_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Social Media</span></h4> <div class="widget-social pc_aligncenter show-text penci-social-colored"> <a href="//www.facebook.com/thisisreno" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook" style="font-size: 14px"></i><span style="font-size: 13px">Facebook</span></a> <a href="//twitter.com/thisisreno" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter" style="font-size: 14px"></i><span style="font-size: 13px">Twitter</span></a> <a href="//www.instagram.com/thisisreno/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram" style="font-size: 14px"></i><span style="font-size: 13px">Instagram</span></a> <a href="//www.linkedin.com/company/6406449" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin" style="font-size: 14px"></i><span style="font-size: 13px">Linkedin</span></a> <a href="//www.youtube.com/c/thisisreno" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play" style="font-size: 14px"></i><span style="font-size: 13px">Youtube</span></a> <a href="//soundcloud.com/thisisreno-com" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-soundcloud" style="font-size: 14px"></i><span style="font-size: 13px">Soundcloud</span></a> <a href="//open.spotify.com/show/78biX0mtXol5MxbWw7iDxY" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-spotify" style="font-size: 14px"></i><span style="font-size: 13px">Spotify</span></a> <a href="/feed/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss" style="font-size: 14px"></i><span style="font-size: 13px">RSS</span></a> </div> </aside><aside id="custom_html-8" class="widget_text widget widget_custom_html"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">About This Is Reno</span></h4><div class="textwidget custom-html-widget">This Is Reno is your source for daily, award-winning news and events for Reno, Sparks, the Truckee Meadows and beyond. We were founded in 2009 and are locally owned and operated. We deliver local, independently produced news about Reno, for the people of Reno, by the people of Reno.</div></aside><aside id="bs_zones-77" class="widget bs_zones"><div><broadstreet-zone zone-id="58693" keywords="not_home_page,not_landing_page,is_article_page,education,news,featured,government,news,news,school-board-to-meet-earlier-as-agendas-remain-lengthy,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside> </div> </div> </div> <footer id="footer-section" class="penci-footer-social-media penci-lazy" itemscope="" itemtype="https://schema.org/WPFooter"> <div class="container"> <div class="footer-logo-copyright footer-not-logo"> <div id="footer-copyright"> <p>© 2021 - All Right Reserved Conrad Communications LLC / This Is Reno. </p> </div> <div class="go-to-top-parent"><a href="#" class="go-to-top"><span><i class="penci-faicon fa fa-angle-up"></i> <br/>Back To Top</span></a></div> </div> </div> </footer> </div> <div id="fb-root"></div> <div class="essb-mobile-sharebottom" data-hideend="false" data-hideend-percent="" data-show-percent="" data-responsive="true"><div class="essb_links essb_counters essb_displayed_sharebottom essb_share essb_template_big essb_720220070 essb_width_columns essb_width_columns_6 essb_size_s essb_width_flex essb_network_align_center essb_responsive_adaptive essb_icon_animation3 essb_nospace print-no" id="essb_displayed_sharebottom_720220070" data-essb-postid="176310" data-essb-position="sharebottom" data-essb-button-style="icon" data-essb-template="big" data-essb-counter-pos="hidden" data-essb-url="https://thisisreno.com/2021/04/school-board-to-meet-earlier-as-agendas-remain-lengthy/" data-essb-fullurl="https://thisisreno.com/2021/04/school-board-to-meet-earlier-as-agendas-remain-lengthy/" data-essb-instance="720220070"><ul class="essb_links_list essb_force_hide_name essb_force_hide"><li class="essb_item essb_totalcount_item" style="display: none !important;" data-essb-hide-till="9" data-counter-pos="hidden"><span class="essb_totalcount essb_t_l_big" data-shares-text="shares"><span class="essb_t_nb">5<span class="essb_t_nb_after">shares</span></span></span></li><li class="essb_item essb_link_facebook nolightbox"> <a href="//www.facebook.com/dialog/feed?app_id=551468291535482&amp;display=popup&amp;name=School+board+to+meet+earlier+as+agendas+remain+lengthy&amp;link=https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F&amp;picture=https://thisisreno.com/wp-content/uploads/2021/03/WCSD_Board-Of-Trustees_3-30-21_EricMarks9864-scaled.jpg&amp;description=School+board+meetings+are+set+to+start+at+2+p.m.+for+now+as+recent+meetings+have+lasted+eight+hours+or+more." title="Share on Share" onclick="essb.window(&#39;https://www.facebook.com/dialog/feed?app_id=551468291535482&amp;display=popup&amp;name=School+board+to+meet+earlier+as+agendas+remain+lengthy&amp;link=https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F&amp;picture=https://thisisreno.com/wp-content/uploads/2021/03/WCSD_Board-Of-Trustees_3-30-21_EricMarks9864-scaled.jpg&amp;description=School+board+meetings+are+set+to+start+at+2+p.m.+for+now+as+recent+meetings+have+lasted+eight+hours+or+more.&#39;,&#39;facebook_advanced&#39;,&#39;720220070&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name essb_noname"></span></a><span class="essb_counter_hidden" data-cnt="5" data-cnt-short=""></span></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="Share on Tweet" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=School%20board%20to%20meet%20earlier%20as%20agendas%20remain%20lengthy&amp;url=https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F&amp;counturl=https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F&amp;related=thisisreno&amp;via=thisisreno&amp;hashtags=#ThisisReno&#39;,&#39;twitter&#39;,&#39;720220070&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name essb_noname"></span></a><span class="essb_counter_hidden" data-cnt="" data-cnt-short=""></span></li><li class="essb_item essb_link_mail nolightbox"> <a href="mailto:?subject=Check%20out%20https%3A%2F%2Fthisisreno.com&amp;body=Hi%2C%20this%20may%20be%20interesting%20you%3A%20School%20board%20to%20meet%20earlier%20as%20agendas%20remain%20lengthy%21%20This%20is%20the%20link%3A%20https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F" title="Share on Email" onclick="essb.tracking_only(&#39;&#39;, &#39;mail&#39;, &#39;720220070&#39;, true);" target="_self" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_mail"></span><span class="essb_network_name essb_noname"></span></a><span class="essb_counter_hidden" data-cnt="" data-cnt-short=""></span></li></ul></div><div class="essb_morepopup essb_morepopup_720220070 essb_morepopup_sharebottom essb-forced-hidden"> <div class="essb_morepopup_header"> <span>Share via</span> <a href="#" class="essb_morepopup_close" onclick="essb.toggle_less_popup(&#39;720220070&#39;); return false;"><i class="essb_icon_close"></i></a> </div> <div class="essb_morepopup_content essb_morepopup_content_720220070"><div class="essb_links essb_displayed_more_popup essb_share essb_template_big essb_1204471021 essb_width_columns essb_width_columns_1 essb_size_s essb_width_flex essb_network_align_center essb_responsive_adaptive essb_icon_animation3 essb_nospace print-no" id="essb_displayed_more_popup_1204471021" data-essb-postid="176310" data-essb-position="more_popup" data-essb-button-style="button" data-essb-template="big" data-essb-counter-pos="insidebeforename" data-essb-url="https://thisisreno.com/2021/04/school-board-to-meet-earlier-as-agendas-remain-lengthy/" data-essb-fullurl="https://thisisreno.com/2021/04/school-board-to-meet-earlier-as-agendas-remain-lengthy/" data-essb-instance="1204471021"><ul class="essb_links_list"><li class="essb_message_before">Please Share</li><li class="essb_item essb_link_linkedin nolightbox"> <a href="//www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=School+board+to+meet+earlier+as+agendas+remain+lengthy&amp;url=https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F" title="Share on Share" onclick="essb.window(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=School+board+to+meet+earlier+as+agendas+remain+lengthy&amp;url=https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F&#39;,&#39;linkedin&#39;,&#39;1204471021&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">Share</span></a></li><li class="essb_item essb_link_messenger nolightbox"> <a href="fb-messenger://share/?link=https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F" title="Share on Send" onclick="essb.fbmessenger(&#39;551468291535482&#39;, &#39;https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F&#39;, &#39;1204471021&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_messenger"></span><span class="essb_network_name">Send</span></a></li><li class="essb_item essb_link_facebook nolightbox"> <a href="//www.facebook.com/plugins/like.php?href=https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F" title="Share on Like" onclick="essb.window(&#39;https://www.facebook.com/plugins/like.php?href=https%3A%2F%2Fthisisreno.com%2F2021%2F04%2Fschool-board-to-meet-earlier-as-agendas-remain-lengthy%2F&#39;,&#39;facebook_like&#39;,&#39;1204471021&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_facebook-official"></span><span class="essb_network_name">Like</span></a></li><li class="essb_item essb_link_whatsapp nolightbox"> <a href="whatsapp://send/?text=School%20board%20to%20meet%20earlier%20as%20agendas%20remain%20lengthy%20https://thisisreno.com/2021/04/school-board-to-meet-earlier-as-agendas-remain-lengthy/" title="Share on WhatsApp" onclick="essb.tracking_only(&#39;&#39;, &#39;whatsapp&#39;, &#39;1204471021&#39;, true);" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_whatsapp"></span><span class="essb_network_name">WhatsApp</span></a></li><li class="essb_item essb_link_sms nolightbox"> <a href="sms:/&amp;body=School%20board%20to%20meet%20earlier%20as%20agendas%20remain%20lengthy%20https:/thisisreno.com/2021/04/school-board-to-meet-earlier-as-agendas-remain-lengthy/" title="Share on Text" onclick="essb.sms(&#39;School%20board%20to%20meet%20earlier%20as%20agendas%20remain%20lengthy%20https://thisisreno.com/2021/04/school-board-to-meet-earlier-as-agendas-remain-lengthy/&#39;, &#39;1204471021&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_sms"></span><span class="essb_network_name">Text</span></a></li></ul></div></div></div> <div class="essb_morepopup_shadow essb_morepopup_shadow_720220070" onclick="essb.toggle_less_popup(&#39;720220070&#39;); return false;"></div></div> <meta http-equiv="imagetoolbar" content="no"/> <script type="text/javascript">
            /*<![CDATA[*/
            document.oncontextmenu = function() {
                return false;
            };
            document.onselectstart = function() {
                if (event.srcElement.type != "text" && event.srcElement.type != "textarea" && event.srcElement.type != "password") {
                    return false;
                }
                else {
                    return true;
                }
            };
            if (window.sidebar) {
                document.onmousedown = function(e) {
                    var obj = e.target;
                    if (obj.tagName.toUpperCase() == 'SELECT'
                            || obj.tagName.toUpperCase() == "INPUT"
                            || obj.tagName.toUpperCase() == "TEXTAREA"
                            || obj.tagName.toUpperCase() == "PASSWORD") {
                        return true;
                    }
                    else {
                        return false;
                    }
                };
            }
            document.ondragstart = function() {
                return false;
            };
            /*]]>*/
        </script> <script type="text/javascript">
        document.addEventListener( 'wpcf7mailsent', function( event ) {
        if( "fb_pxl_code" in event.detail.apiResponse){
          eval(event.detail.apiResponse.fb_pxl_code);
        }
      }, false );
    </script> <div id="fb-pxl-ajax-code"></div><div id="pico-widget-container"></div><script type="text/javascript" src="https://thisisreno.com/wp-content/themes/soledad/js/libs-script.min.js" id="penci-libs-js-js"></script> <script type="text/javascript" id="main-scripts-js-extra">
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/thisisreno.com\/wp-admin\/admin-ajax.php","nonce":"08f84cce4b","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script> <script type="text/javascript" src="https://thisisreno.com/wp-content/themes/soledad/js/main.min.js" id="main-scripts-js"></script> <script type="text/javascript" id="penci_ajax_like_post-js-extra">
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/thisisreno.com\/wp-admin\/admin-ajax.php","nonce":"08f84cce4b","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script> <script type="text/javascript" src="https://thisisreno.com/wp-content/themes/soledad/js/post-like.min.js" id="penci_ajax_like_post-js"></script> <script type="text/javascript" id="penci_ajax_more_posts-js-extra">
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/thisisreno.com\/wp-admin\/admin-ajax.php","nonce":"08f84cce4b","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script> <script type="text/javascript" src="https://thisisreno.com/wp-content/themes/soledad/js/more-post.min.js" id="penci_ajax_more_posts-js"></script> <script type="text/javascript" id="penci_ajax_archive_more_scroll-js-extra">
/* <![CDATA[ */
var SOLEDADLOCALIZE = {"url":"https:\/\/thisisreno.com\/wp-admin\/admin-ajax.php","nonce":"08f84cce4b","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script> <script type="text/javascript" src="https://thisisreno.com/wp-content/themes/soledad/js/archive-more-post.min.js" id="penci_ajax_archive_more_scroll-js"></script> <script type="text/javascript" src="https://thisisreno.com/wp-includes/js/comment-reply.min.js" id="comment-reply-js"></script> <script type="text/javascript" src="https://thisisreno.com/wp-includes/js/wp-embed.min.js" id="wp-embed-js"></script> <script type="text/javascript" src="https://cdn.onesignal.com/sdks/OneSignalSDK.js?" async="async" id="remote_sdk-js"></script> <script type="text/javascript" id="lazy-load-scripts">const loadScriptsTimer=setTimeout(loadScripts,10*1000);const userInteractionEvents=["mouseover","keydown","touchmove","touchstart"];userInteractionEvents.forEach(function(event){window.addEventListener(event,triggerScriptLoader,{passive:!0})});function triggerScriptLoader(){loadScripts();clearTimeout(loadScriptsTimer);userInteractionEvents.forEach(function(event){window.removeEventListener(event,triggerScriptLoader,{passive:!0})})}
function loadScripts(){document.querySelectorAll("script[data-type='lazy']").forEach(function(elem){elem.setAttribute("src",elem.getAttribute("data-src"))})}</script> <script type="application/ld+json">{
    "@context": "http://schema.org",
    "@type": "EntertainmentBusiness",
    "image": "https://thisisreno.com/wp-content/uploads/2018/05/Reno-City-Flag-5.jpg",
    "priceRange": "n/a",
    "telephone": "775-391-5252",
    "additionalType": [
        "http://thisisreno.com/about/",
        "http://thisisreno.com/category/news/",
        "thisisreno.com/calendar/"
    ],
    "name": "This Is Reno: Online News and Events",
    "logo": "https://thisisreno.com/wp-content/uploads/2019/12/TIR-Stylized-R.png",
    "description": "This Is Reno is your source for daily Reno news and events for Reno, Sparks, the Truckee Meadows and beyond. We were founded in 2009 and are locally owned and operated.",
    "openingHours": "Mo-Fri 8:00-18:00",
    "geo": {
        "@type": "GeoCoordinates",
        "latitude": null,
        "longitude": null
    },
    "url": "https://thisisreno.com",
    "sameAs": [
        "https://www.facebook.com/ThisIsReno/",
        "https://twitter.com/ThisIsReno",
        "https://instagram.com/thisisreno",
        "https://www.linkedin.com/company/thisisreno/",
        "https://www.youtube.com/user/ThisisReno2"
    ],
    "contactPoint": {
        "@type": "ContactPoint",
        "telephone": "+1-775-391-5252",
        "contactType": "sales",
        "email": "bob@thisisreno.com",
        "contactOption": "",
        "areaServed": [
            "US"
        ],
        "availableLanguage": [
            "English"
        ]
    },
    "address": {
        "@type": "PostalAddress",
        "addressCountry": "United States",
        "addressLocality": "Reno",
        "addressRegion": "NV",
        "postalCode": "89502",
        "streetAddress": "705 S. Wells Avenue"
    }
}</script> <div class="essbasc-popup essbasc-popup-follow essbasc-title-mode" data-popup-width="500" data-single="false"><div class="essbasc-popup-header"><span> </span><a href="#" class="essbasc-popup-close" onclick="essbasc_popup_close(); return false;"><i class="essb_icon_close"></i></a></div><div class="essbasc-popup-content"><div class="essbasc-fans onecol"></div></div></div><div class="essbasc-popup-shadow" onclick="essbasc_popup_close();"></div><div class="essb_mailform" data-error="Please fill all form fields"><div class="essb_mailform_header"><div class="heading">Send this to a friend</div></div><div class="essb_mailform_content"><input type="text" id="essb_mailform_from" class="essb_mailform_content_input" placeholder="Your email"/><input type="text" id="essb_mailform_from_name" class="essb_mailform_content_input" placeholder="Your name"/><input type="text" id="essb_mailform_to" class="essb_mailform_content_input" placeholder="Recipient email"/><div class="essb_mailform_content_buttons"><button id="essb_mailform_btn_submit" class="essb_mailform_content_button" onclick="essb_mailform_send();">Send</button><button id="essb_mailform_btn_cancel" class="essb_mailform_content_button" onclick="essb_close_mailform(); return false;">Cancel</button></div><input type="hidden" id="essb_mail_salt" value="678084530"/><input type="hidden" id="essb_mail_instance"/><input type="hidden" id="essb_mail_post"/></div></div><div class="essb_mailform_shadow"></div><script type="text/javascript" src="https://thisisreno.com/wp-content/easysocialsharebuttons-assets/compiled/2566c291e59e185c12a331fef1e235f3.js" async=""></script><script type="text/javascript">!function(a){"use strict";var b=function(b,c,d){function j(a){if(e.body)return a();setTimeout(function(){j(a)})}function l(){f.addEventListener&&f.removeEventListener("load",l),f.media=d||"all"}var g,e=a.document,f=e.createElement("link");if(c)g=c;else{var h=(e.body||e.getElementsByTagName("head")[0]).childNodes;g=h[h.length-1]}var i=e.styleSheets;f.rel="stylesheet",f.href=b,f.media="only x",j(function(){g.parentNode.insertBefore(f,c?g:g.nextSibling)});var k=function(a){for(var b=f.href,c=i.length;c--;)if(i[c].href===b)return a();setTimeout(function(){k(a)})};return f.addEventListener&&f.addEventListener("load",l),f.onloadcssdefined=k,k(l),f};"undefined"!=typeof exports?exports.loadCSS=b:a.loadCSS=b}("undefined"!=typeof global?global:this); !function(a){if(a.loadCSS){var b=loadCSS.relpreload={};if(b.support=function(){try{return a.document.createElement("link").relList.supports("preload")}catch(a){return!1}},b.poly=function(){for(var b=a.document.getElementsByTagName("link"),c=0;c<b.length;c++){var d=b[c];"preload"===d.rel&&"style"===d.getAttribute("as")&&(a.loadCSS(d.href,d,d.getAttribute("media")),d.rel=null)}},!b.support()){b.poly();var c=a.setInterval(b.poly,300);a.addEventListener&&a.addEventListener("load",function(){b.poly(),a.clearInterval(c)}),a.attachEvent&&a.attachEvent("onload",function(){a.clearInterval(c)})}}}(this);</script> <script async="" data-type="lazy" data-src="https://www.googletagmanager.com/gtag/js?id=UA-11652878-1"></script> <script data-type="lazy" data-src="data:text/javascript;base64,CiAgd2luZG93LmRhdGFMYXllciA9IHdpbmRvdy5kYXRhTGF5ZXIgfHwgW107CiAgZnVuY3Rpb24gZ3RhZygpe2RhdGFMYXllci5wdXNoKGFyZ3VtZW50cyk7fQogIGd0YWcoJ2pzJywgbmV3IERhdGUoKSk7CgogIGd0YWcoJ2NvbmZpZycsICdVQS0xMTY1Mjg3OC0xJyk7Cg=="></script>  <script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="thisisreno_com",_audins_did=148879;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=194-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.thisisreno_com,DomainId.148879" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=2&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script></body></html>